System Performance

Incident Report for FastTrack360-APAC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 17:49 AEST

Investigating

Several customers have reported and our investigations confirm, that the FastTrack360 system is experiencing slowness. Our Infrastructure Team and Cloud Partner are investigating the possible cause and we will keep you updated as the investigation progresses.
Posted Jul 02, 2025 - 16:33 AEST
This incident affects: Applications (Recruit, Time & Attendance, Rates & Rules, Payroll, Billing, Reporting), Services (Advertise - Posting, Applicant Processing, Timesheet Interpretation, Email, SMS, API, Cloud Storage, MarketPlace, Bullhorn-FastTrack Integration, eInvoicing), and Infrastructure (Primary Datacenter, Secondary Datacenter, Tertiary Datacenter, DNS, Deployment Services).