Planned Maintenance
Scheduled for Dec 28, 22:00 AEDT  -  Dec 29, 01:00 AEDT
Update
A slightly extended period is required this month due to the install of database security patches.
Posted Dec 18, 2024 - 15:37 AEDT
Scheduled
During Standard Monthly Maintenance, the FastTrack360 platform will be unavailable to all users, for the duration specified.

If the team completes the work earlier, they'll advise customers the system is available.
Posted Dec 12, 2024 - 15:34 AEDT
This scheduled maintenance affects: Applications (Recruit, Time & Attendance, Rates & Rules, Payroll, Billing, Reporting), Services (Advertise - Posting, Applicant Processing, Timesheet Interpretation, Email, SMS, API, MarketPlace, Bullhorn-FastTrack Integration), and Infrastructure (Primary Datacenter, Secondary Datacenter, Tertiary Datacenter, DNS, Deployment Services).